| Passwort vergessen?
Sie sind nicht angemeldet. |  Anmelden

Sprache auswählen:

Wumpus-Gollum-Forum von "Welt der Radios".
Fachforum für Sammler, Interessierte, Bastler
Sie sind nicht angemeldet.
 Anmelden

Philips PM3310 korrupter Eprom?
  •  
 1 2
 1 2
10.10.20 19:27
Chris_7867 

WGF-Einsteiger

10.10.20 19:27
Chris_7867 

WGF-Einsteiger

Philips PM3310 korrupter Eprom?

Guten Tag!

Meine Name ist Chris und ich bin der Neue.

Ich hab mich bei Euch im Forum angemeldet, da ich bei der Suche nach einer Lösung für mein Problem festgestellt habe, dass hier einige Kenner versammelt sind, die sich mit älteren Oszilloskopen auskennen.

Das Sorgenkind ist ein Philips PM3310, eines der ersten Digitaloszilloskope von Anfang er 1980er Jahre. Alles 8bit, ein schönes TTL Gräberfeld, dankenswerterweise auf 8 bzw 9 handliche Steckkarten aufgeteilt. Wodurch das Ganze recht übersichtlich bleibt. Alles in allem: Ein früher Amiga, nur als Oszilloskop.

Das Teil würde als defekt verkauft, funktionierte jedoch auf Anhieb. Der Vorbesitzer kannte sich wohl nicht so gut aus.
Es gab nur einen Fehler, ein schadhafter X2 Kondensator im Netzteil, offenbar ein Fehler der heute häufiger vorkommt. Die Spannungsfestigkeit war mit 250V etwas knapp ausgelegt. Zur Zeit von 220V ging das wohl gut, heute mit 240V jedoch nicht mehr. Die Funktionsfähigkeit hat der Kondensator jedoch nicht beeinträchtigt.

Ich freute mich also an dem Gerät, bis plötzlich der Bootvorgang stockte. Ja, das Ding bootet, es ist ja ein 8bit Computer ...

Ich habe also alle Spannungen überprüft und auch die Pufferelkos auf dem Prozessorbord ausgetauscht, keine Besserung.

In einem holländischen Forum fand ich dann einen Hinweis: Offenbar altern die Eproms, in denen das Programm abgelegt ist. Einige Bits flippen und nichts geht mehr, da die Integrität der Speicherinhalte beim Bootvorgang überprüft wird. Soweit ich die Diskussion im dem Forum verstanden habe (Mein Holländisch reicht zum radebrechenden Lesen, zu mehr aber auch nicht), gibt es wohl einen Trick, mit dem man Eproms, bei dem die Bits flippen, dazu überreden kann, doch noch einmal die richtigen Bits auszugeben: Man soll die Versorgungsspannung erhöhen, dann rutschen Bits wieder an die richtige Stelle. Jedoch ist dies wohl nichts für den Dauerbetrieb, eher so eine Notoperation um die Daten zu retten um sie dann in ein neues Eprom umzubetten.

Bevor ich mich jedoch an eine solche Operation wage, such ich lieber um kundigen Rat. Ich hoffe ich finde den hier.

Über Antworten würde ich mich freuen.

Danke fürs Lesen!

Beste Grüße
Chris

PS: Ich habe das Servicemanual vom Philips PM3311. Das ich der Nachfolger, aber dem 3310 sehr ähnlich.

Debo gefällt der Beitrag.
!
!!! Fotos, Grafiken nur über die Upload-Option des Forums, KEINE FREMD-LINKS auf externe Fotos.    

!!! Keine Komplett-Schaltbilder, keine Fotos, keine Grafiken, auf denen Urheberrechte Anderer (auch WEB-Seiten oder Foren) liegen!
Solche Uploads werden wegen der Rechtslage kommentarlos gelöscht!

Keine Fotos, auf denen Personen erkennbar sind, ohne deren schriftliche Zustimmung.
10.10.20 20:01
technikfreund 

WGF-Premiumnutzer

10.10.20 20:01
technikfreund 

WGF-Premiumnutzer

Re: Philips PM3310 korrupter Eprom?

Hallo Chris,

wenn der X2 Kondensator so ein WIMA Typ in einem durchsichtigen / gelben Gehäuse ist,
gehört dieser getauscht, die Dinger fliegen einem nämlich gerne um die Ohren, meistens sind die schon rissig.

Kleine Anekdote dazu: Schön am messen hier mit dem Philips Oszi, plötzlich lauter Knall und große Rauchwolke,
oh nein, mein schönes Oszi, aber das Philips bliebt erstaunlicher Weise an.
Stecker ausgesteckt, Gehäuse geöffnet, Kondensator am Netzeingang war explodiert, abgekniffen und weiter gearbeitet.

Falls du Hilfe bei der niederländischen Sprache brauchst, ich kann niederländisch sprechen, lesen und schreiben.

Viele Grüße

Technikfreund

Zuletzt bearbeitet am 10.10.20 20:03

10.10.20 20:11
Chris_7867 

WGF-Einsteiger

10.10.20 20:11
Chris_7867 

WGF-Einsteiger

Re: Philips PM3310 korrupter Eprom?

Hallo Technikfreund!


technikfreund:

Kleine Anekdote dazu: Schön am messen hier mit dem Philips Oszi, plötzlich lauter Knall und große Rauchwolke,
oh nein, mein schönes Oszi, aber das Philips bliebt erstaunlicher Weise an.
Stecker ausgesteckt, Gehäuse geöffnet, Kondensator am Netzeingang war explodiert, abgekniffen und weiter gearbeitet.


Genauso wars bei mir!

technikfreund:

Falls du Hilfe bei der niederländischen Sprache brauchst, ich kann niederländisch sprechen, lesen und schreiben.


Danke! Ich komme drauf zurück, wenn ichs brauche

Grüße
Chris

10.10.20 22:36
Debo 

WGF-Premiumnutzer

10.10.20 22:36
Debo 

WGF-Premiumnutzer

Re: Philips PM3310 korrupter Eprom?

Hallo chris 7867,

willkommen hier! Ich habe einige uralte und alte Philips Oszis in meiner Sammlung - und auch einen PM 3311. Der ist allerdings nicht durchgesehen und steht im Aussenlager

Ich bin jetzt leider kein Spezialist für EPROM Ersatz für dein Problem. Ich kann dazu nichts sagen. Vielleicht melden sich noch µP und Peripherie erfahrene.
Es ist aber immer gut, wenn man ein Zweitgerät hat, welches funktioniert. Dann kann man Boards und Bauteile zum quertauschen.

Philips Oszis sind nun nicht gerade beliebt. Philips ist eine Marke, die machte immer irgendwelche Spezialitäten. Das war bei Unterhaltungselektronik so, wie hier auch bei den Messgeräten. Bei Oszis z.B. Reed-Relais als Eingangsabschwächerschalter. Diese "verflixten" Drehklemmverriegelung der Deckel. SMD-Transistoren schon in den Siebzigern verwendet. Aussetzende Schiebeschalter und Taster. So vergossene Dünnfilmschaltungen auf Sockeln. Falls defekt gibt es keinen Ersatz ausser vom Zweitgerät. Eben so Eimerkettenschaltungen bei diesem PM 3310 u.ä. Schwarz werdende LCD-Displays bei den PM 3295 400MHz Geräten etc.
Aus Prüffeld in Fertigungen sind die Kisten oft in üblem Zustand. Die teilweise Nextellack beschichteten Gehäuse haben durch Klebrigkeit volles Schmutz angezogen. Ferner ist diese o.a. Drehklemmverriegelung der Deckel oft defekt wenn die Gummi versprödet sind und dann halten sie nicht mehr richtig. Kontrastscheiben sind entweder ab Werk Dunkelbraungrau = wenig attraktiv. Oder blaue Scheiben auch oft gelblich vergilbt. Daneben gibt es auch elektrische Probleme. Kurzum sie sind pflegebedürfig ehe sie erstmals wieder Leben zeigen.

Was du aber auf jeden Fall mal machen musst, die Elkos prüfen. Im Netzteil und übrige Boards. Tantals können anfällig sein, müssen aber nicht. Wenn die Spannungen stimmen würde ich die mal lassen bis es zu Ausfällen kommt. Aber Elkos sind oft ausgetrocknet und haben Kapazität verloren. Diese Funkentstör Kondis - von Rifa oder Wima, bekommen eigentlich nur Risse und ziehen über die Zeit Feuchtigkeit. Dadurch steigen die Verluste und sie werden warm und gehen hopps!

Nun hoffe ich mal jemand kennt sich mit der EPROM Geschichte aus und das interessante Gerät wird wieder laufen. Beleuchtete Schalterfenster und diese MikroLED Anzeigen haben die normalen Scopes PM 3215 bis 67 nämlich nicht.

Gruss
Debo

Hier noch ein paar Prospektbilder, damit sich jeder ein Bild von dem Modell machen kann. 1982 kam der glaub auf den Markt.













Zuletzt bearbeitet am 11.10.20 10:37

Datei-Anhänge
Philips PM 3310 Deckblatt.jpg Philips PM 3310 Deckblatt.jpg (181x)

Mime-Type: image/jpeg, 214 kB

Pilips PM 3310 Seite Vollansicht verkleinert.jpg Pilips PM 3310 Seite Vollansicht verkleinert.jpg (176x)

Mime-Type: image/jpeg, 126 kB

Pilips PM 3310 Seite 2 verkleinert.jpg Pilips PM 3310 Seite 2 verkleinert.jpg (172x)

Mime-Type: image/jpeg, 324 kB

Pilips PM 3310 Seite 3 verkleinert.jpg Pilips PM 3310 Seite 3 verkleinert.jpg (178x)

Mime-Type: image/jpeg, 230 kB

Pilips PM 3310 Seite 4 verkleinert.jpg Pilips PM 3310 Seite 4 verkleinert.jpg (169x)

Mime-Type: image/jpeg, 281 kB

Pilips PM 3310 Seite 1 verkleinert.jpg Pilips PM 3310 Seite 1 verkleinert.jpg (179x)

Mime-Type: image/jpeg, 410 kB

11.10.20 00:32
Chris_7867 

WGF-Einsteiger

11.10.20 00:32
Chris_7867 

WGF-Einsteiger

Re: Philips PM3310 korrupter Eprom?

Danke für die spannenden Infos und das geile Prospekt! Ja, das Teil ist schon schick, hoffentlich kriege ich es wieder zum Laufen.


Debo:

Was du aber auf jeden Fall mal machen musst, die Elkos prüfen. Im Netzteil und übrige Boards. Tantals ...


Ja, alte Tantals können eklig sein. Am schlimmsten finde ich die Teile aus den 70ern. Die können das Gerät komplett lahm legen. Elkos und Tantals prüfen ist daher das erste was ich mache.

Chris

11.10.20 10:33
Debo 

WGF-Premiumnutzer

11.10.20 10:33
Debo 

WGF-Premiumnutzer

Re: Philips PM3310 korrupter Eprom?

Hallo,

ja, aber ich empfehle nicht komplett vorsorglich alle Tantals zu wechseln. Das ist ja eine Riesenarbeit. Du wirst ja dies Oszilloskop nicht jeden Tag in Betrieb haben. Nur wenn in deinem Gerät welche ausfallen, würde ich die im notwendigem Umfang tauschen. Grundsätzlich ist immer zuerst mit seinen Sinnen zu arbeiten. Sehen, hören, riechen, fühlen. Manche Tantals werden eine zeitlang heiss, bevor sie dann Kurzschluss machen. Verändern dabei ihre Farbe. Da merkt man dann - da passiert was.
Ich habe auch nur vom PM 3311 die kompletten Unterlagen da. Sind ein Bedienungsordner und ein Serviceordner in dunklem Orangerot.
Das Modell PM 3311 war noch glaub 1987/88 im Lieferprogramm. Ich schau morgen mal nach dem Katalog, habe ihn jetzt nicht hier greifbar. Dann kann ich auch den damaligen Preis nennen.

Gruss
Debo

11.10.20 13:14
WalterBar 

WGF-Premiumnutzer

11.10.20 13:14
WalterBar 

WGF-Premiumnutzer

Re: Philips PM3310 korrupter Eprom?

Hallo Chris,

in Sachen EPROM habe ich auch keinen wirklichen Ratschlag zu geben. Ich rate aber dringend davor ab, die Speicher auszulesen, zu löschen und dann neu zu programmieren. NUR AUSLESEN und möglichst neue Speicher gleichen Grösse und Zugriffszeit anzuschaffen und diese dann programmieren.

Meine Erfahrungen bezüglich 27C128 habe ich hier beschrieben:

https://www.wumpus-gollum-forum.de/forum...=112&page=2


Gruss
Walter

11.10.20 14:34
Chris_7867 

WGF-Einsteiger

11.10.20 14:34
Chris_7867 

WGF-Einsteiger

Re: Philips PM3310 korrupter Eprom?

Hallo

Danke für die Antworten.

@ Debo
Oh Gott. Da erinnerst Du mich an mein Siemens Oscillar M07190. Als ich es bekam, ging nichts mehr. Mehrere Sicherungen im Netzteil waren durch und es gab Kurzschlüsse auf zwei Versorgungslinien. Ich glaube es waren +12V und -12V. Schuldig waren natürlich Tantals.
Nur: Das M07190 ist äußerst robust gebaut. Ein sehr stabiler Alurahmen in einem massiven Stahlblechgehäuse. Offenbar sollte das Gerät unbedingt auch den dritten Weltkrieg überleben. Nachteil: an einige Platinen kommt man nur sehr umständlich ran und manche Platinen sind mit bis zu 8 Schrauben befestigt. An die Arbeitszeit von Servicemitarbeitern haben die Siemenstechniker offenbar keinen Gedanken verschwendet.
Also musste ich den Fehler eingrenzen. Zum Glück hat das Gerät schon Platinensteckverbinder. (Jedenfalls an den meisten Stellen) Es war dann die Platine mit dem Horizontalverstärker mit etwa 20 Tantals. Und was soll ich sagen, der Kurzschluß war natürlich der vorletzte. Auf den anderen Platinen habe ich die Tantals draufgelassen. Ich hatte schon ca 20 Schrauben im Kästchen.

zum PM3310
Das Gerät hat einige Features, die ich vorher noch bei keinem Osci gesehen habe. Z.B. eine Langzeitfunktion. Es hat 10 div in der Horizontalen, die entsprechen 256 Datenpunkten. In der längsten Aufzeichnungsfunktion lässt es sich pro div eine Stunde Zeit. Einen Durchgang sind also 600 min = 10 Stunden. Da es 4 Speicherbänke hat, die es nacheinander auffüllt, kann man eine 40 Stunden Langzeitmessung machen. Das Resultat kann man dann wahlweise auf einem Plotter ausdrucken bzw. über eine IEC-Schnittstelle (GPIB) ausgeben. (Das GPIB-Interface hab ich jedoch bisher noch nicht zum Laufen bekommen.)

@ Walter
Klar! Genau das hatte ich vor: Neue, bisher unbenutzte, kompatible Eproms besorgen, die alten auslesen, die neuen beschreiben und einsetzen - und beten.
Aber das mit dem Kenwood Amateurfunk Sender/Empfänger finde ich ziemlich krass. Da hab ich es mit meinen Oszilloskopen ja noch richtig bequem. Respekt für die Geduld!

Liebe Grüße,
Chris

11.10.20 15:38
HB9 

WGF-Premiumnutzer

11.10.20 15:38
HB9 

WGF-Premiumnutzer

Re: Philips PM3310 korrupter Eprom?

Hallo Chris,

zum EPROM: Der Ersatz muss nicht unbedingt derselbe Typ sein, der verbaut ist. Einerseits können problemlos CMOS-EPROMs verwendet werden (also die 27Cxxx-Typen), andererseits kann auch ein EPROM mit höherer Kapazität verwendet werden, wenn es Beschaffungsprobleme gibt. In diesem Fall muss man schauen, welche Pegel die Pins mit den zusätzlichen Adressbits haben und entsprechend den Original-Inhalt an die richtige Adresse programmieren.

Die Herausforderung dürfte sein, an die richtigen Daten zu kommen. Im Allgemeinen neigen die Bits in EPROMs dazu, mit den Jahren von '0' nach '1' zu wechseln. Somit hilft es unter Umständen, das EPROM mehrmals auszulesen, auch bei verschiedenen Temperaturen (Kühlschrank bis etwa 50°C). Man vergleicht dann die gelesenen Daten und nimmt bei allen Differenzen das Byte mit den meisten Nullen, also dem kleinsten HEX-Wert. Besser ist natürlich, bei einem identischen funktionierenden Gerät das EPROM auszulesen.

Ganz generell sollte man von EPROMs Sicherungskopien machen. Eine EPROM- (oder Flash-) Zelle ist ja nichts anderes als ein geladener Kondensator, wobei die Ladung besser 'eingesperrt' ist als bei einem gewöhnlichen Kondensator. Mit der Zeit geht sie aber verloren, die Hersteller gaben seinerzeit 10 Jahre Speicherzeit an, heute sind es meistens 20 Jahre. In der Praxis ist es bei gemässigter Umgebungstemperatur zwar einiges mehr, aber die Geräte aus der Anfangszeit der EPROMs sind mitterweile auch 30..40 Jahre alt.

Gruss HB9

11.10.20 18:04
Chris_7867 

WGF-Einsteiger

11.10.20 18:04
Chris_7867 

WGF-Einsteiger

Re: Philips PM3310 korrupter Eprom?

Hallo HB9,

danke für die Tipps!

Damit ist für mich erst mal die Reihenfolge klar:
- Augen aufhalten nach passenden EPROMs. Original bei mir 24pol, drei mal INTEL D2716, einmal AM2732, also geht 27C16 bzw 27C32 auch.
- Währenddessen Chips bei unterschiedlichen Bedingungen mehrfach auslesen, auf Unterschiede achten. Die Dateien mit weniger Nullen nach dev/null, die mit mehr Nullen sichern.

Frage: Irgendwo habe ich gelesen, dass man auch die Versorgungsspannung variieren kann/soll. Etwa von 4,5V bis max 5,5V. Ist das empfehlenswert oder gefährlich? lt Datenblatt von INTEL darf die Versorgungsspannung 5V +- 10% betragen. Kann das etwas bringen?

Zweite Frage: Gibt es auch passende Chips die sich einfacher programmieren lassen, ohne speziellen programmer? (Bisher hatte ich noch nie mit EPROMs was zu tun.)

Beste Grüße
Chris

 1 2
 1 2
Funktionsfähigkeit   korrupter   Versorgungsspannung   Dünnfilmschaltungen   Programmieralgorithmus   Programmierspannung   Eingangsabschwächerschalter   Beschaffungsprobleme   Programmier-Algorithmus   Umgebungstemperatur   Unterhaltungselektronik   Uralt-Gesichtsbräuner   Aufzeichnungsfunktion   Horizontalverstärker   Philips   Quecksilberdampflampe   Eimerkettenschaltungen   Platinensteckverbinder   Drehklemmverriegelung   Spannungsfestigkeit